summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-07 13:56:49 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-20 11:50:43 +0200
commitc9b1b4f9c66fd45cae526428d8a483c2d3ff3788 (patch)
treee930c2c161d448217b9013ccdb333b482fdaf8e0 /gnu
parent8c9610be195de27bdfda46f90b306f50b4029192 (diff)
downloadguix-c9b1b4f9c66fd45cae526428d8a483c2d3ff3788.tar.gz
gnu: Add python-rpy2.
* gnu/packages/python.scm (python-rpy2, python2-rpy2): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4fd5eef892..82aff00b89 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -48,9 +48,11 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages networking)
   #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages statistics)
   #:use-module (gnu packages texlive)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages tls)
@@ -2724,6 +2726,42 @@ those files.  It can also efficiently manipulate ranges of integers using set
 operators such as union, intersection, and difference.")
     (license asl2.0)))
 
+(define-public python-rpy2
+  (package
+    (name "python-rpy2")
+    (version "2.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://pypi.python.org/packages/source/r/rpy2"
+                           "/rpy2-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1dp4l8hpv0jpf4crz4wis6in3lvwk86cr5zvpw410y4a07rrbqjk"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-six" ,python-six)
+       ("readline" ,readline)
+       ("icu4c" ,icu4c)
+       ("pcre" ,pcre)
+       ("r" ,r)))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://rpy.sourceforge.net/")
+    (synopsis "Python interface to the R language")
+    (description "rpy2 is a redesign and rewrite of rpy.  It is providing a
+low-level interface to R from Python, a proposed high-level interface,
+including wrappers to graphical libraries, as well as R-like structures and
+functions.")
+    (license gpl3+)))
+
+(define-public python2-rpy2
+  (let ((rpy2 (package-with-python2 python-rpy2)))
+    (package (inherit rpy2)
+      (native-inputs
+       `(("python2-singledispatch" ,python2-singledispatch)
+         ,@(package-native-inputs rpy2))))))
+
 (define-public python-scipy
   (package
     (name "python-scipy")