summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-07-08 21:20:17 -0400
committerCarl Dong <contact@carldong.me>2019-07-08 21:20:17 -0400
commitca3757e1c2fdc1576d17239a57f0a493a47bc6dc (patch)
tree0e4e7e868bf448f935821284828834f9b16ea0e0 /gnu
parentbcfc54fff80ef6a11fc53c61db333a8065bbfeef (diff)
downloadguix-ca3757e1c2fdc1576d17239a57f0a493a47bc6dc.tar.gz
gnu: glibc: Add 2.27 supported locales patch.
The 'glibc-supported-locales.patch' was updated for glibc 2.29, breaking
compatibility with 2.27. Add a 2.27-specific supported locales patch.

* gnu/packages/patches/glibc-2.27-supported-locales.patch: New file.
* gnu/packages/base.scm (glibc-2.27)[source](patches): Use
'glibc-2.27-supported-locales.patch' instead.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/base.scm2
-rw-r--r--gnu/packages/patches/glibc-2.27-supported-locales.patch33
3 files changed, 35 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bac1a92741..f63ff1ff1e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -876,6 +876,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/glibc-2.28-supported-locales.patch     	\
   %D%/packages/patches/glibc-2.29-git-updates.patch     	\
   %D%/packages/patches/glibc-supported-locales.patch     	\
+  %D%/packages/patches/glibc-2.27-supported-locales.patch     	\
   %D%/packages/patches/glusterfs-use-PATH-instead-of-hardcodes.patch		\
   %D%/packages/patches/glog-gcc-5-demangling.patch		\
   %D%/packages/patches/gmp-arm-asm-nothumb.patch		\
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f26145cb0b..5878cbec5e 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -854,7 +854,7 @@ with the Linux kernel.")
                                        "glibc-versioned-locpath.patch"
                                        "glibc-allow-kernel-2.6.32.patch"
                                        "glibc-reinstate-prlimit64-fallback.patch"
-                                       "glibc-supported-locales.patch"
+                                       "glibc-2.27-supported-locales.patch"
                                        "glibc-CVE-2018-11236.patch"
                                        "glibc-CVE-2018-11237.patch"))))
     (properties `((lint-hidden-cve . ("CVE-2017-18269")))))) ; glibc-2.27-git-fixes
diff --git a/gnu/packages/patches/glibc-2.27-supported-locales.patch b/gnu/packages/patches/glibc-2.27-supported-locales.patch
new file mode 100644
index 0000000000..2888052bb8
--- /dev/null
+++ b/gnu/packages/patches/glibc-2.27-supported-locales.patch
@@ -0,0 +1,33 @@
+This patch is taken from debian's glibc package (generate-supported.mk).
+It install the localedata/SUPPORTED file of the glibc. This file lists
+all the supported locales of the glibc.
+
+diff --git a/localedata/Makefile.old b/localedata/Makefile
+index 34877c0..a61d9b9 100644
+--- a/localedata/Makefile.old
++++ b/localedata/Makefile
+@@ -91,7 +91,8 @@ endif
+ # Files to install.
+ install-others := $(addprefix $(inst_i18ndir)/, \
+ 			      $(addsuffix .gz, $(charmaps)) \
+-			      $(locales))
++			      $(locales)) \
++                   $(inst_i18ndir)/SUPPORTED
+ 
+ tests: $(objdir)/iconvdata/gconv-modules
+ 
+@@ -195,6 +196,14 @@ endif
+ 
+ include SUPPORTED
+ 
++$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
++	for locale in $(SUPPORTED-LOCALES); do \
++		[ $$locale = true ] && continue; \
++		echo $$locale | sed 's,/, ,' >> LOCALES; \
++	done
++	$(make-target-directory)
++	$(INSTALL_DATA) LOCALES $@
++
+ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
+ 
+ # Sometimes the whole collection of locale files should be installed.