summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorErik Eduardo <eduarskate8@gmail.com>2024-02-08 17:32:00 +0000
committerChristopher Baines <mail@cbaines.net>2024-02-14 13:15:40 +0000
commitca47a1346a94d58db8a4828bcfdcd924549b6616 (patch)
tree15cac0d0c20c19ef2c94c8b442a0588407146e72 /gnu
parent3fa4a8baf3fb735a09ed915abd4f61600e2d77e2 (diff)
downloadguix-ca47a1346a94d58db8a4828bcfdcd924549b6616.tar.gz
gnu: river: Add river.desktop file.
* gnu/packages/zig-xyz.scm (river)[arguments]: Add 'install-wayland-session
phase after 'install phase to install the river.desktop file inside
share/wayland-sessions directory.

Change-Id: I19fbcfa09a6b06ed602ec4be1b06cc6e2cd2a9a1
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zig-xyz.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..f01c120cc3 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -52,7 +52,17 @@
     (build-system zig-build-system)
     (arguments
      (list
-      #:zig-build-flags #~(list "-Dxwayland")   ;experimental xwayland support
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-wayland-session
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let* ((out (assoc-ref outputs "out"))
+                     (wayland-sessions
+                      (string-append out "/share/wayland-sessions")))
+                (mkdir-p wayland-sessions)
+                (install-file "contrib/river.desktop"
+                              wayland-sessions)))))
+      #:zig-build-flags #~(list "-Dxwayland") ;experimental xwayland support
       #:zig-release-type "safe"))
     (native-inputs (list libevdev
                          libxkbcommon