summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-08-18 13:14:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-22 10:57:01 +0200
commitca823a1600bf99e4ca83b17b8cf0586790c180ba (patch)
tree8b0013ee14fbe6e84030c3bde8845e11d16a5d05 /gnu
parent3534165413f8b9d299d034ae31ef94b560f6c0bc (diff)
downloadguix-ca823a1600bf99e4ca83b17b8cf0586790c180ba.tar.gz
gnu: Add r-gensa.
* gnu/packages/cran.scm (r-gensa): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 03801ecc47..b2a55d871b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3533,6 +3533,24 @@ coordinates.")
 @end enumerate\n")
     (license license:gpl2+)))
 
+(define-public r-gensa
+  (package
+    (name "r-gensa")
+    (version "1.1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "GenSA" version))
+              (sha256
+               (base32
+                "03xqwxm7v7rnihx730a4p65dfwhjh4345r3d78y0qxxplk8d76cx"))))
+    (properties `((upstream-name . "GenSA")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=GenSA")
+    (synopsis "Generalized simulated annealing")
+    (description "This package performs search for the global minimum of a very
+complex non-linear objective function with a very large number of optima.")
+    (license license:gpl2)))
+
 (define-public r-geosphere
   (package
     (name "r-geosphere")