summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:55:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:40 +0200
commitca94533250562194da66fcc19d1be97adcc2938d (patch)
treeba501b06a3f508add91d8e9e1630e631b2c5a62e /gnu
parentde87aca007500a5885e71a79cf50a0281b18419a (diff)
downloadguix-ca94533250562194da66fcc19d1be97adcc2938d.tar.gz
gnu: Add texlive-roboto.
* gnu/packages/tex.scm (texlive-roboto): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f6ea129d68..c6f4b68d9a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22390,6 +22390,32 @@ package solves the problem by extending ideas described in M. I. Grinchuk
 mathematical packages.")
     (license license:lppl1.3+)))
 
+(define-public texlive-roboto
+  (package
+    (name "texlive-roboto")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/roboto/"
+                   "fonts/enc/dvips/roboto/"
+                   "fonts/map/dvips/roboto/"
+                   "fonts/opentype/google/roboto/"
+                   "fonts/tfm/google/roboto/"
+                   "fonts/type1/google/roboto/"
+                   "fonts/vf/google/roboto/"
+                   "tex/latex/roboto/")
+             (base32
+              "1gbg9p9y6a2fis88qfcsscksrkkcnqvsrhdkak2jm2dfjnq6v2n8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/roboto")
+    (synopsis "Support for the Roboto family of fonts")
+    (description
+     "This package provides LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX support for
+the Roboto Sans, Roboto Condensed, Roboto Mono, Roboto Slab and Roboto Serif
+families of fonts, designed by Christian Robertson and Greg Gazdowicz.")
+    (license (list license:asl2.0 license:silofl1.1 license:lppl))))
+
 (define-public texlive-rrgtrees
   (package
     (name "texlive-rrgtrees")