summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-24 02:18:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-24 12:42:35 +0200
commitcafde61d81af33a9cec1164d8422d3b4e9037d48 (patch)
tree33c38f60c0581198126637f2d78e4f1b3ad66611 /gnu
parente1cab74a0b70bab55dee5c36f8804e14de813dae (diff)
downloadguix-cafde61d81af33a9cec1164d8422d3b4e9037d48.tar.gz
gnu: Add emacs-jq-mode.
* gnu/packages/emacs-xyz.scm (emacs-jq-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6caa8d1106..1efcf8f6a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11708,6 +11708,26 @@ from within Emacs.  Restclient runs queries from a plan-text query sheet,
 displays results pretty-printed in XML or JSON with @code{restclient-mode}")
       (license license:public-domain))))
 
+(define-public emacs-jq-mode
+  (package
+    (name "emacs-jq-mode")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ljos/jq-mode")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xk0if5i9cz4w06lx8v1vdm112pn1ybqgfw048sx15yyvfzgril1"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/ljos/jq-mode")
+    (synopsis "Major mode for editing jq queries")
+    (description
+     "Jq mode is an Emacs major mode for editing jq-scripts.")
+    (license license:gpl3+)))
+
 (define-public emacs-whitespace-cleanup-mode
   (let ((commit "72427144b054b0238a86e1348c45d986b8830d9d")
         (revision "1"))