summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-07-10 12:16:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-07-10 12:45:35 +0300
commitcb5b51498b98d2b2f2805ec46216f806a2d97210 (patch)
tree865844dc39b01cdba92f1f59978f4eac793f5ffb /gnu
parent05f386f103bbd0145ac2fcf8b920bb27f1b518a4 (diff)
downloadguix-cb5b51498b98d2b2f2805ec46216f806a2d97210.tar.gz
gnu: mujs: Update to 1.0.6 [fixes CVE-2019-1141{1,2,3}, CVE-2019-12798].
* gnu/packages/javascript.scm (mujs): Update to 1.0.6.
[source]: Download using url-fetch.
[arguments]: Update 'install-shared-library phase.
[home-page]: Update to new home-page.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/javascript.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index e7dcd7962d..9e1818dfaf 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -417,32 +417,28 @@ external server.")
 (define-public mujs
   (package
     (name "mujs")
-    (version "1.0.5")
+    (version "1.0.6")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://git.ghostscript.com/mujs.git")
-                    (commit version)))
-              (file-name (string-append name "-" version "-checkout"))
+              (method url-fetch)
+              (uri (string-append "https://mujs.com/downloads/mujs-"
+                                  version ".tar.xz"))
               (sha256
                (base32
-                "0pkv26jxwgv5ax0ylfmi4h96h79hj4gvr95218ns8wngnmgr1ny6"))))
+                "1q9w2dcspfp580pzx7sw7x9gbn8j0ak6dvj75wd1ml3f3q3i43df"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (delete 'configure)  ; no configure
          (add-after 'install 'install-shared-library
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "build/release/libmujs.so"
-                             (string-append out "/lib"))))))
+           (lambda* (#:key (make-flags '()) #:allow-other-keys)
+             (apply invoke "make" "install-shared" make-flags))))
        #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
                           (string-append "CC=gcc"))
        #:tests? #f))                    ; no tests
     (inputs
      `(("readline" ,readline)))
-    (home-page "https://artifex.com/mujs/")
+    (home-page "https://mujs.com/")
     (synopsis "JavaScript interpreter written in C")
     (description "MuJS is a lightweight Javascript interpreter designed for
 embedding in other software to extend them with scripting capabilities.  MuJS