summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-10 02:47:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 03:08:45 +0200
commitcb9da5d171b1a9806aa3cbd28c2d514a0bcda8a2 (patch)
treed86dfdc99c8a5d674fcf812a00edcc924eff6eb0 /gnu
parent28e14a6726c9c571189381c0c37285e428afb7fc (diff)
downloadguix-cb9da5d171b1a9806aa3cbd28c2d514a0bcda8a2.tar.gz
gnu: asio: Update to 1.12.1.
* gnu/packages/networking.scm (asio): Update to 1.12.1.
[source]: Use upstream release tarballs.
[native-inputs, arguments]: Remove cruft needed to build from git.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm27
1 files changed, 6 insertions, 21 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index aa7059eb50..91cc150207 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1897,23 +1897,16 @@ eight bytes) tools
 (define-public asio
   (package
     (name "asio")
-    (version "1.12.0")
+    (version "1.12.1")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/chriskohlhoff/asio.git")
-             (commit (string-join (cons name (string-split version #\.))
-                                  "-"))))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/asio/asio/"
+                           version " (Stable)/" name "-" version ".tar.bz2"))
        (sha256
         (base32
-         "04dg8kpgriay7q62mqcq2gl439k5y4mf761zghsd6wfl0farh3mx"))))
+         "0nln45662kg799ykvqx5m9z9qcsmadmgg6r5najryls7x16in2d9"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)))
     (inputs
      `(("boost" ,boost)
        ("openssl" ,openssl)))
@@ -1921,15 +1914,7 @@ eight bytes) tools
      `(#:configure-flags
        (list
         (string-append "--with-boost=" (assoc-ref %build-inputs "boost"))
-        (string-append "--with-openssl=" (assoc-ref %build-inputs "openssl")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'chdir-to-asio
-           (lambda _
-             (chdir "asio")))
-         (add-before 'configure 'bootstrap
-           (lambda _
-             (invoke "sh" "autogen.sh"))))))
+        (string-append "--with-openssl=" (assoc-ref %build-inputs "openssl")))))
     (home-page "https://think-async.com/Asio")
     (synopsis "C++ library for ASynchronous network I/O")
     (description "Asio is a cross-platform C++ library for network and