summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-07 19:53:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:00:21 +0200
commitcbce5de26581f61d05f90740d8478f070762d591 (patch)
tree4e832c0ff78f5a89f214be5c9c2552407c1b4f3b /gnu
parent14a671d8f9e628e06b40356b9a505df94eb89154 (diff)
downloadguix-cbce5de26581f61d05f90740d8478f070762d591.tar.gz
gnu: Add java-httpcomponents-httpmime.
* gnu/packages/java.scm (java-httpcomponents-httpmime): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b3c1cb9814..6b36bc6f5e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2149,6 +2149,21 @@ feature-rich package implementing the client side of the most recent HTTP
 standards and recommendations.")
     (license license:asl2.0)))
 
+(define-public java-httpcomponents-httpmime
+  (package (inherit java-httpcomponents-httpclient)
+    (name "java-httpcomponents-httpmime")
+    (arguments
+     `(#:jar-name "httpcomponents-httpmime.jar"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "httpmime") #t)))))
+    (inputs
+     `(("java-httpcomponents-httpclient" ,java-httpcomponents-httpclient)
+       ("java-httpcomponents-httpcore" ,java-httpcomponents-httpcore)
+       ("java-junit" ,java-junit)
+       ("java-hamcrest-core" ,java-hamcrest-core)))))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")