summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:05:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:41 +0200
commitcc4f1a381dce5618ff9058d9913fdd3bd9dd903a (patch)
tree2741df5ed76c614285a36fc1fdada6adb02a7e11 /gnu
parenta16e86bcf26cfe6c011422726214a0e4e5208df6 (diff)
downloadguix-cc4f1a381dce5618ff9058d9913fdd3bd9dd903a.tar.gz
gnu: Add texlive-projlib.
* gnu/packages/tex.scm (texlive-projlib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2ffaf71e5a..8a68ff27f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24163,6 +24163,29 @@ drawings (using TikZ) for laboratory stuff.")
 for 15-18 years olds.")
     (license license:lppl1.3c)))
 
+(define-public texlive-projlib
+  (package
+    (name "texlive-projlib")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/projlib/" "source/latex/projlib/"
+                   "tex/latex/projlib/")
+             (base32
+              "1yhn0xj4xwnr7ngmv8skdj89gi8i71v710d899g9pnjgfkk7w35d")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-create-theorem))
+    (home-page "https://ctan.org/pkg/projlib")
+    (synopsis "Tools to simplify your workflow")
+    (description
+     "ProjLib is a collection of tools to help you write LaTeX documents.
+With the main package ProjLib loaded, you no longer need to set up the
+@code{theorem}-like environments, nor to manually configure the appropriate
+multilingual settings.  In addition, a series of auxiliary functionalities are
+introduced.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-proof-at-the-end
   (package
     (name "texlive-proof-at-the-end")