summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 01:51:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:36:52 +0200
commitcc82816416a82bca909b2eff5b256713eb08b433 (patch)
treeade64e2e87929ea000099252ece614bf7ee08c21 /gnu
parent56b4a1d53f1a9d67f2406cd874b80c7372ac3d7b (diff)
downloadguix-cc82816416a82bca909b2eff5b256713eb08b433.tar.gz
gnu: python-parted: Update to 3.11.6.
* gnu/packages/disk.scm (python-parted): Update to 3.11.6.
(python2-parted): Drop unsupported Python 2 variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index bf03ece6fc..cab3602560 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -520,7 +520,7 @@ a card with a smaller capacity than stated.")
 (define-public python-parted
   (package
     (name "python-parted")
-    (version "3.11.2")
+    (version "3.11.6")
     (source
      (origin
        (method git-fetch)
@@ -529,7 +529,7 @@ a card with a smaller capacity than stated.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0r6916n3w4vldxrq30a3z2iagvxgly4vfmlidjm65vwqnyv17bvn"))))
+        (base32 "1xgrqhvn44vr3676j5sy2x3xfv2dzf7vncg25cmrsmkbd49x3z5j"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -555,9 +555,6 @@ a card with a smaller capacity than stated.")
     (description "This package provides @code{parted} bindings for Python.")
     (license license:gpl2+)))
 
-(define-public python2-parted
-  (package-with-python2 python-parted))
-
 (define-public duperemove
   (package
     (name "duperemove")