summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:43:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:58 +0200
commitccd3df80c3423ce1fab967b10eb184fd067fdac9 (patch)
treeaeab248e988e3db13d2fb8618c8aab394eca23f1 /gnu
parent9f92a955799f45999e5b05d6ee1f83a475e33820 (diff)
downloadguix-ccd3df80c3423ce1fab967b10eb184fd067fdac9.tar.gz
gnu: Add texlive-dviout-util.
* gnu/packages/tex.scm (texlive-dviout-util): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1ba7441789..b7a9a75432 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1819,6 +1819,29 @@ file.  It also supports XeTeX XDV format.")
 @command{kpathsea} recursive file searching.")
     (license license:gpl3+)))
 
+(define-public texlive-dviout-util
+  (package
+    (name "texlive-dviout-util")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/chkdvifont.1"
+                   "doc/man/man1/chkdvifont.man1.pdf"
+                   "doc/man/man1/dvispc.1"
+                   "doc/man/man1/dvispc.man1.pdf")
+             (base32
+              "098pksgf2iamq96rmzg5fw7i9dlpvdksficsz1bf8k8z4djnbk8n")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Utilities from the @code{dviout} package")
+    (description
+     "This package provides two utilities: @command{chkdvifont}, which check
+fonts in DVI/TFM/JFM/FONT files, and @command{dvispc}, which corrects the
+page-independence of DVI file using color specials or tpic specials, and
+transforms between a DVI file and a text file.")
+    (license license:expat)))
+
 (define-public texlive-dvipsconfig
   (package
     (name "texlive-dvipsconfig")