summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothee Mathieu <timothee.mathieu@inria.fr>2024-02-16 07:56:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-16 08:01:23 +0100
commitcd225af6e6df2aa01b5c0d4b0f895efdc5cdd95e (patch)
treeb770ac4f4a7cda45de674b8ca815ca62aad223bb /gnu
parentbd87416648929f38c0173f047776d7675ea8a10d (diff)
downloadguix-cd225af6e6df2aa01b5c0d4b0f895efdc5cdd95e.tar.gz
gnu: Add python-farama-notifications.
* gnu/packages/python-xyz.scm (python-farama-notifications): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Change-Id: Icbf19b9d6be1051dc92bf638e0a37f0831183c50
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29e2bfd222..2dd8a12af5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -146,6 +146,7 @@
 ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29649,6 +29650,37 @@ usable as a configuration language.  This Python package implements parsing and
 dumping of JSON5 data structures.")
     (license license:asl2.0)))
 
+(define-public python-farama-notifications
+  (package
+    (name "python-farama-notifications")
+    (version "0.0.4")
+    (source
+     ;; The version on pypi does not include tests.
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Farama-Foundation/Farama-Notifications")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1k1x48xpvhankw7vbjp20ljwran247aphc2qncqrxivrkgzwjjji"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python3" "tests/ci-test.py")))))))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/Farama-Foundation/Farama-Notifications")
+    (synopsis "Notifications for all Farama Foundation maintained libraries")
+    (description
+     "This package allows for providing notifications for all Farama
+Foundation maintained libraries.")
+    (license license:expat)))
+
 (define-public python-freetype-py
   (package
     (name "python-freetype-py")