summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-30 23:48:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-31 14:22:19 +0200
commitcebcf3533ab83233121434254a6ae7b8c35cfa1f (patch)
tree2a9623ecfda3c4f88706a189a2f31ef9c8464c20 /gnu
parent7f7532a847f1232fa8797a5d6d6b2a7e34278854 (diff)
downloadguix-cebcf3533ab83233121434254a6ae7b8c35cfa1f.tar.gz
gnu: zsh: Patch failing test that uses egrep.
* gnu/packages/patches/zsh-egrep-failing-test.patch: New file.
* gnu/packages/shells.scm (zsh): Patch it.
* gnu/local.mk (dist_patch_DATA): Register it.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/patches/zsh-egrep-failing-test.patch11
-rw-r--r--gnu/packages/shells.scm3
3 files changed, 15 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 58437b7a0e..21f0993a3f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2040,7 +2040,8 @@ dist_patch_DATA =						\
   %D%/packages/patches/xterm-370-explicit-xcursor.patch		\
   %D%/packages/patches/xygrib-fix-finding-data.patch		\
   %D%/packages/patches/yggdrasil-extra-config.patch	\
-  %D%/packages/patches/zig-use-system-paths.patch
+  %D%/packages/patches/zig-use-system-paths.patch		\
+  %D%/packages/patches/zsh-egrep-failing-test.patch
 
 MISC_DISTRO_FILES =				\
   %D%/packages/ld-wrapper.in
diff --git a/gnu/packages/patches/zsh-egrep-failing-test.patch b/gnu/packages/patches/zsh-egrep-failing-test.patch
new file mode 100644
index 0000000000..10828ca6bb
--- /dev/null
+++ b/gnu/packages/patches/zsh-egrep-failing-test.patch
@@ -0,0 +1,11 @@
+--- a/Test/E01options.ztst	2023-03-30 21:34:12.372309112 +0200
++++ b/Test/E01options.ztst	2023-03-30 21:34:33.212335339 +0200
+@@ -649,7 +649,7 @@
+ >noktarg1
+ >0 1
+ 
+-  showopt() { setopt | egrep 'localoptions|ksharrays'; }
++  showopt() { setopt | grep -E 'localoptions|ksharrays'; }
+   f1() { setopt localoptions ksharrays; showopt }
+   f2() { setopt ksharrays; showopt }
+   setopt kshoptionprint
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5ca8d842c2..26cbbe67dd 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -467,7 +467,8 @@ history mechanism, job control and a C-like syntax.")
                            ".tar.xz")))
               (sha256
                (base32
-                "06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))))
+                "06crvpqbpm8sq5c215f4b985z7npwnqnj0i0g53hnq6fp8h3b5xn"))
+              (patches (search-patches "zsh-egrep-failing-test.patch"))))
     (build-system gnu-build-system)
     (arguments `(#:configure-flags
                  `("--with-tcsetpgrp"