summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-03-30 13:01:25 +0200
committerLars-Dominik Braun <lars@6xq.net>2023-03-30 13:03:42 +0200
commitcf26ee1f99f84f817f96269541073846d546026b (patch)
tree4fbe77308dd891efbbef58c59878b4e1fb78435e /gnu
parent35b208cb2205040829f38ede32aa2363eca26388 (diff)
downloadguix-cf26ee1f99f84f817f96269541073846d546026b.tar.gz
gnu: python-trio: Run pytest on tests directory only.
Failing to do so causes cryptic module load errors.

* gnu/packages/python-xyz.scm (python-trio)[arguments]: Add path parameter
to invoke.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6a9ea04840..c11b9a9d65 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24613,7 +24613,8 @@ project.")
                          ;; OSError: protocol not found.
                          " and not test_getprotobyname"
                          ;; EOFError: Ran out of input.
-                         " and not test_static_tool_sees_all_symbols"))))))))
+                         " and not test_static_tool_sees_all_symbols")
+                        "trio/tests")))))))
     (native-inputs
      (list python-astor
            python-ipython