summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-25 16:36:11 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-25 16:36:11 +0200
commitcf9fd501ea8ea8d37c5219f6b6438dc3dd900b97 (patch)
tree25cd45cdeda087d87ec5b0e89fee2883a4d9724b /gnu
parentc8c6bba5a7001adef4f79a83c00cc24b697e8ed4 (diff)
downloadguix-cf9fd501ea8ea8d37c5219f6b6438dc3dd900b97.tar.gz
gnu: findutils: Fix cross-compilation.
* gnu/packages/base.scm (findutils): Reinstate cross-compilation
  #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4452108abf..85380549ff 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -236,13 +236,13 @@ You can use the sdiff command to merge two files interactively.")
     `(("patch/absolute-paths"
        ,(search-patch "findutils-absolute-paths.patch"))))
    (arguments
-    `(#:patches (list (assoc-ref %build-inputs "patch/absolute-paths")))
+    `(#:patches (list (assoc-ref %build-inputs "patch/absolute-paths"))
 
-    ;; TODO: Work around cross-compilation failure.
-    ;; See <http://savannah.gnu.org/bugs/?27299#comment1>.
-    ;; `(#:configure-flags '("gl_cv_func_wcwidth_works=yes")
-    ;;   ,@(arguments cross-system))
-    )
+      ;; Work around cross-compilation failure.
+      ;; See <http://savannah.gnu.org/bugs/?27299#comment1>.
+      ,@(if (%current-target-system)
+            '(#:configure-flags '("gl_cv_func_wcwidth_works=yes"))
+            '())))
    (synopsis "Operating on files matching given criteria")
    (description
     "The GNU Find Utilities are the basic directory searching utilities of