summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 15:09:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:13 -0400
commitcfa04b1c6c640e9450eaf574fb60ce493825a3ee (patch)
treef1bb0e00ad45459e0720384f88f546f1930ad8ea /gnu
parent0fa989172df685170590e42b6eadc151cbd2acba (diff)
downloadguix-cfa04b1c6c640e9450eaf574fb60ce493825a3ee.tar.gz
gnu: ocaml-dose3: Disable tests to avoid Python 2 dependencies.
* gnu/packages/ocaml.scm (ocaml-dose3)[tests?]: Set to #f.
[native-inputs]: Use new style.  Remove python-2 and python2-pyyaml.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e6d6bc7a89..5591e08d78 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -24,6 +24,7 @@
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -663,21 +664,20 @@ underlying solvers like Cplex, Gurobi, Lpsolver, Glpk, CbC, SCIP or WBO.")
                 "ocaml-dose3-Install-mli-cmx-etc.patch"))))
     (build-system ocaml-build-system)
     (arguments
-     `(#:configure-flags
+     `(#:tests? #f                      ;the test suite requires python 2
+       #:configure-flags
        ,#~(list (string-append "SHELL="
                                #+(file-append (canonical-package bash-minimal)
                                               "/bin/sh")))
        #:make-flags
        ,#~(list (string-append "LIBDIR=" #$output "/lib/ocaml/site-lib"))))
     (propagated-inputs
-      (list ocaml-graph ocaml-cudf ocaml-extlib ocaml-re))
+     (list ocaml-graph ocaml-cudf ocaml-extlib ocaml-re))
     (native-inputs
-      `(("perl" ,perl)
-        ("python" ,python-2) ; for a test script
-        ("python2-pyyaml" ,python2-pyyaml) ; for a test script
-        ("ocaml-extlib" ,ocaml-extlib)
-        ("ocamlbuild" ,ocamlbuild)
-        ("ocaml-cppo" ,ocaml-cppo)))
+     (list perl
+           ocaml-extlib
+           ocamlbuild
+           ocaml-cppo))
     (home-page "https://www.mancoosi.org/software/")
     (synopsis "Package distribution management framework")
     (description "Dose3 is a framework made of several OCaml libraries for