summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-03 00:53:55 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-03 17:41:39 +0100
commitcfaa1bec8f402eacd1f4f380cd694c0409b21349 (patch)
tree2cf6fb3f1853556e63a3b21e9bf8285b1fc7a58f /gnu
parent633e44167235f0e34aa8ab0ef16962a5ce60869d (diff)
downloadguix-cfaa1bec8f402eacd1f4f380cd694c0409b21349.tar.gz
gnu: sbcl-log4cl: Update to 1.1.3-1.8c48d6f.
* gnu/packages/lisp-xyz.scm (sbcl-log4cl): Update to 1.1.3-1.8c48d6f.
  [native-inputs]: Add stefil.
  [arguments]: Enable tests.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c87c26ca80..145ae12643 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4734,30 +4734,30 @@ theory accurate to internal-time-units-per-second.")
   (sbcl-package->ecl-package sbcl-cl-log))
 
 (define-public sbcl-log4cl
-  (let ((commit "611e094458504b938d49de904eab141285328c7c")
+  (let ((commit "8c48d6f41d3a1475d0a91eed0638b9eecc398e35")
         (revision "1"))
     (package
       (name "sbcl-log4cl")
-      (build-system asdf-build-system/sbcl)
-      (version "1.1.2")
+      (version (git-version "1.1.3" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/sharplispers/log4cl")
                (commit commit)))
-         (file-name (git-file-name name version))
+         (file-name (git-file-name "log4cl" version))
          (sha256
-          (base32
-           "08jly0s0g26b56hhpfizxsb4j0yvbh946sd205gr42dkzv8l7dsc"))))
-      ;; FIXME: tests require stefil, sbcl-hu.dwim.stefil wont work
-      (arguments
-       `(#:tests? #f))
-      (inputs `(("bordeaux-threads" ,sbcl-bordeaux-threads)))
-      (synopsis "Common Lisp logging framework, modeled after Log4J")
+          (base32 "0166d9aip366pbpdk5gsi2f6xad6q61lssxgbrypa8zslwjn8736"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("stefil" ,sbcl-stefil)))
+      (inputs
+       `(("bordeaux-threads" ,sbcl-bordeaux-threads)))
       (home-page "https://github.com/7max/log4cl")
-      (description "This is a Common Lisp logging framework that can log at
-various levels and mix text with expressions.")
+      (synopsis "Common Lisp logging framework, modeled after Log4J")
+      (description
+       "This is a Common Lisp logging framework that can log at various levels
+and mix text with expressions.")
       (license license:asl2.0))))
 
 (define-public cl-log4cl