summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-19 13:07:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:29 +0200
commitd1e66d2ddf0b7a2a7385404b6f69bc009d53661d (patch)
treea56357a73bb59de32c5c296e0b178ebe52e1d305 /gnu
parent78d24b78d36a333576a7a32c03a191eff4e449f4 (diff)
downloadguix-d1e66d2ddf0b7a2a7385404b6f69bc009d53661d.tar.gz
gnu: Add python-ipfsspec.
* gnu/packages/python-xyz.scm (python-ipfsspec): New variable.

Change-Id: I1fe0c2523616b9567501ef369c07b61fcacbee81
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..57d34dae34 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8626,6 +8626,34 @@ tracebacks and better introspection than Python's standard @command{pdb}
 debugger, with which it shares the same interface.")
     (license license:bsd-3)))
 
+(define-public python-ipfsspec
+  (package
+    (name "python-ipfsspec")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ipfsspec" version))
+       (sha256
+        (base32 "1y4ad9schc76j2lynm7vpwi4q4jzi9vv843zfpisbp8zqgm0rr7l"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      '(list "-m not local_gw"
+             ;; Require local gateway
+             "--ignore=test/test_gateway.py"
+             ;; Require internet
+             "--ignore=test/test_async.py"
+             "--ignore=test/test_ipfs.py")))
+    (propagated-inputs (list python-aiohttp python-fsspec python-requests))
+    (native-inputs (list python-pytest python-pytest-asyncio))
+    (home-page "https://github.com/fsspec/ipfsspec")
+    (synopsis "Read-only implementation of fsspec for IPFS")
+    (description "This package provides a read-only implementation of
+@code{fsspec} for IPFS.")
+    (license license:expat)))
+
 (define-public python-pdbpp
   ;; The latest release lacks support for Python 3.10; use the latest commit
   ;; of the master branch (see: https://github.com/pdbpp/pdbpp/issues/503).