summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-11 13:30:58 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-11 13:30:58 +0800
commitd1f9e45e5d55d6ccc78bd26bf56091bb83c19bfa (patch)
treec1fcaf627190c2cb1d022e99cd2e29dd03ab1021 /gnu
parentbe84118181c274b0dd39f0a1d78b3f721f3e5bca (diff)
downloadguix-d1f9e45e5d55d6ccc78bd26bf56091bb83c19bfa.tar.gz
gnu: cdparanoia: Don't use patchelf.
* gnu/packages/cdrom.scm (cdparanoia): Remove 'patchelf' from inputs.
  [arguments]: Remove #:modules, #:imported-modules and #:phases.  Pass
  'LDFLAGS=-Wl,-rpath=...' as #:configure-flags.
  [origin]: Add 'snippet'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cdrom.scm28
1 files changed, 8 insertions, 20 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index e93503f25a..3383fb653d 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -159,29 +159,17 @@ files.")
              (sha256
               (base32
                "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
-             (patches (list (search-patch "cdparanoia-fpic.patch")))))
+             (patches (list (search-patch "cdparanoia-fpic.patch")))
+             (modules '((guix build utils)))
+             (snippet
+              ;; Make libraries respect LDFLAGS.
+              '(substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
+                 (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname")))))
     (build-system gnu-build-system)
-    (inputs
-     `(("patchelf" ,patchelf)))
     (arguments
      `(#:tests? #f ; there is no check target
-       #:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (guix build rpath)
-                  (srfi srfi-26))
-       #:imported-modules (,@%gnu-build-system-modules
-                           (guix build rpath))
-       #:phases
-        (alist-cons-after
-         'strip 'add-lib-to-runpath
-         (lambda* (#:key outputs #:allow-other-keys)
-           (let* ((out (assoc-ref outputs "out"))
-                  (lib (string-append out "/lib")))
-             ;; Add LIB to the RUNPATH of all the executables.
-             (with-directory-excursion out
-               (for-each (cut augment-rpath <> lib)
-                         (find-files "bin" ".*")))))
-         %standard-phases)))
+       #:configure-flags ; Add $libdir to the RUNPATH of all the executables.
+       (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
     (home-page "http://www.xiph.org/paranoia/")
     (synopsis "Audio CD reading utility")
     (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM