summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-03-30 18:04:32 +0200
committerLars-Dominik Braun <lars@6xq.net>2023-03-31 13:24:47 +0200
commitd20bc0dbc2844d74cca13b030f0b66e46417bd1d (patch)
tree9283fe9331c98fa773d2ec0a208e20e24c51c106 /gnu
parentcdba566261428d8949fcc4f7c7066a578e3009eb (diff)
downloadguix-d20bc0dbc2844d74cca13b030f0b66e46417bd1d.tar.gz
gnu: python-testtools-bootstrap: Update to 2.6.0.
Supports Python 3.10 and 3.11.

* gnu/packages/check.scm (python-testtools-bootstrap): Update to 2.6.0.
[propagated-inputs]: Remove python-extras, which is not a dependency.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ffb81a7f03..6f87831c00 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1763,19 +1763,18 @@ subprocess and see the output as well as any file modifications.")
 (define-public python-testtools-bootstrap
   (package
     (name "python-testtools-bootstrap")
-    (version "2.5.0")
+    (version "2.6.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "testtools" version))
        (sha256
         (base32
-         "0gxjbjk93jjqi491k4s9rh3ia37v21yifd35pvizv7sgv4rk9hap"))))
+         "02mkphygx8897617m8qnmj0alksyvvfcjmazzfxyrlzjq0a5xdi8"))))
     (build-system python-build-system)
     (arguments '(#:tests? #f))
     (propagated-inputs
-     `(("python-extras" ,python-extras)
-       ("python-fixtures" ,python-fixtures-bootstrap)
+     `(("python-fixtures" ,python-fixtures-bootstrap)
        ("python-pbr" ,python-pbr-minimal)))
     (home-page "https://github.com/testing-cabal/testtools")
     (synopsis