summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-30 22:19:35 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-30 22:19:35 +0200
commitd274f499a35f416d49533c0d1e2b76cb3cebdcb8 (patch)
tree82c313654c19439013b7d3ff6914612d5de38f32 /gnu
parent9ceb630c587beb187b52243f751e3ebc2b437a32 (diff)
downloadguix-d274f499a35f416d49533c0d1e2b76cb3cebdcb8.tar.gz
gnu: glib: Update to 2.38.0.
* gnu/packages/glib.scm (glib): Update to 2.38.0 and drop rewriting of GTESTER.
* gnu/packages/patches/glib-tests-homedir.patch: Update patch for 2.38.0.
* gnu/packages/patches/glib-tests-desktop.patch: Update patch for 2.38.0 and
    drop test dbus-appinfo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm14
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch69
-rw-r--r--gnu/packages/patches/glib-tests-homedir.patch12
3 files changed, 54 insertions, 41 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a6b86795a8..cfaea3b958 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -105,14 +105,14 @@ shared NFS home directories.")
 (define glib
   (package
    (name "glib")
-   (version "2.37.1")
+   (version "2.38.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/"
-                                name "/2.37/"
+                                name "/" (string-take version 4) "/"
                                 name "-" version ".tar.xz"))
             (sha256
-             (base32 "1lp705q0g9jlfj24x8fpgjh7awmmara5iyj9kz5lhd49sr9s813k"))))
+             (base32 "0cpzqadqk6z6bmb79p04pykxc8x57rvshh33414cnk41bvgaf4vm"))))
    (build-system gnu-build-system)
    (outputs '("out"                        ; everything
               "doc"))                      ; 20 MiB of GTK-Doc reference
@@ -153,13 +153,7 @@ shared NFS home directories.")
                                  "glib/tests/utils.c"
                                  "tests/spawn-test.c")
                     (("/bin/sh")
-                     (string-append (assoc-ref inputs "bash") "/bin/sh")))
-
-                  ;; Honor $(TESTS_ENVIRONMENT).
-                  (substitute* (find-files "." "^Makefile(\\.in)?$")
-                    (("^GTESTER[[:blank:]]*=(.*)$" _ rest)
-                     (string-append "GTESTER = $(TESTS_ENVIRONMENT) "
-                                    rest))))
+                     (string-append (assoc-ref inputs "bash") "/bin/sh"))))
                 %standard-phases)
 
       ;; Note: `--docdir' and `--htmldir' are not honored, so work around it.
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
index a92662886e..0824e68963 100644
--- a/gnu/packages/patches/glib-tests-desktop.patch
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -53,36 +53,55 @@ database, the `update-desktop-database' program, which we don't provide.
 -----------------------------
 The hunk below removes tests that depend on `gdbus-testserver.py',
 because that script depends on python-gobject.
-
---- glib-2.34.3/gio/tests/Makefile.in	2012-11-26 20:08:54.000000000 +0100
-+++ glib-2.34.3/gio/tests/Makefile.in	2013-01-17 23:09:44.000000000 +0100
-@@ -60,15 +60,8 @@ DIST_COMMON = $(srcdir)/Makefile.am $(sr
- noinst_PROGRAMS = $(am__EXEEXT_6) $(am__EXEEXT_8)
- @HAVE_DBUS_DAEMON_TRUE@am__append_1 = \
- @HAVE_DBUS_DAEMON_TRUE@	actions 		\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection	\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection-loss	\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection-slow	\
- @HAVE_DBUS_DAEMON_TRUE@	gdbus-names		\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy		\
- @HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy-threads	\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy-well-known-name \
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-introspection	\
--@HAVE_DBUS_DAEMON_TRUE@	gdbus-threading		\
- @HAVE_DBUS_DAEMON_TRUE@	gdbus-export		\
- @HAVE_DBUS_DAEMON_TRUE@	gdbus-error		\
- @HAVE_DBUS_DAEMON_TRUE@	gdbus-bz627724		\
-
+ 
+--- glib-2.38.0.orig/gio/tests/Makefile.in	2013-09-23 23:07:46.000000000 +0200
++++ glib-2.38.0/gio/tests/Makefile.in	2013-09-30 21:55:35.000000000 +0200
+@@ -172,19 +172,12 @@
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-auth				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-bz627724				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-close-pending			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection-loss			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-connection-slow			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-error				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-exit-on-close			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-export				\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-introspection			\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-names				\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-threads			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-proxy-well-known-name		\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-test-codegen			\
+-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gdbus-threading				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	gmenumodel				\
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@	$(NULL)
+ 
 
 The test below depends on the availability /etc/passwd to dbus-daemon.
 
---- glib-2.34.3/gio/tests/gdbus-auth.c	2013-01-19 14:32:14.000000000 +0100
-+++ glib-2.34.3/gio/tests/gdbus-auth.c	2013-01-19 14:32:20.000000000 +0100
-@@ -264,6 +264,7 @@ main (int   argc,
+--- glib-2.38.0.orig/gio/tests/gdbus-auth.c     2013-05-07 20:26:07.000000000 +0200
++++ glib-2.38.0/gio/tests/gdbus-auth.c  2013-09-30 19:42:27.000000000 +0200
+@@ -284,6 +284,7 @@
  {
    gint ret;
- 
+
 +  return 0;
    setlocale (LC_ALL, "C");
+
+   temp_dbus_keyrings_setup ();
+
+
+The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see
+   https://launchpad.net/ubuntu/+source/glib2.0/2.37.5-1ubuntu1
+
+--- glib-2.38.0.orig/gio/tests/dbus-appinfo.c   2013-09-05 12:43:41.000000000 +0200
++++ glib-2.38.0/gio/tests/dbus-appinfo.c        2013-09-30 21:57:21.000000000 +0200
+@@ -278,6 +278,7 @@
+ int
+ main (int argc, char **argv)
+ {
++  return 0;
+   g_test_init (&argc, &argv, NULL);
  
-   g_type_init ();
+   session_bus_up ();
+
diff --git a/gnu/packages/patches/glib-tests-homedir.patch b/gnu/packages/patches/glib-tests-homedir.patch
index cb9538ef8c..0a2bcf1a23 100644
--- a/gnu/packages/patches/glib-tests-homedir.patch
+++ b/gnu/packages/patches/glib-tests-homedir.patch
@@ -15,18 +15,18 @@ chroot build environment.  Thus, disable them.
  
    ret = g_test_run();
 
---- glib-2.34.3/gio/tests/gdbus-peer.c	2013-01-16 17:38:09.000000000 +0100
-+++ glib-2.34.3/gio/tests/gdbus-peer.c	2013-01-16 17:38:12.000000000 +0100
-@@ -1828,11 +1828,6 @@ main (int   argc,
- 
+--- glib-2.38.0.orig/gio/tests/gdbus-peer.c     2013-08-08 12:00:40.000000000 +0200
++++ glib-2.38.0/gio/tests/gdbus-peer.c  2013-09-30 19:36:40.000000000 +0200
+@@ -1746,11 +1746,6 @@
+
    g_test_add_func ("/gdbus/peer-to-peer", test_peer);
    g_test_add_func ("/gdbus/delayed-message-processing", delayed_message_processing);
 -  g_test_add_func ("/gdbus/nonce-tcp", test_nonce_tcp);
+-
 -  g_test_add_func ("/gdbus/tcp-anonymous", test_tcp_anonymous);
 -  g_test_add_func ("/gdbus/credentials", test_credentials);
--  g_test_add_func ("/gdbus/overflow", test_overflow);
 -  g_test_add_func ("/gdbus/codegen-peer-to-peer", codegen_test_peer);
- 
+
    ret = g_test_run();
  
 --- glib-2.37.1/gio/tests/gdbus-exit-on-close.c	2013-06-07 23:41:34.000000000 +0200