summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-09-25 00:49:57 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-25 15:12:33 +0200
commitd27f8db19503357d946e4c098740ac95a89e4570 (patch)
tree176a76bb7872f4489bb5e8b6d29bd447fb55cd8f /gnu
parentc4af643391340b643f890bf404e5bd8ff6c0763c (diff)
downloadguix-d27f8db19503357d946e4c098740ac95a89e4570.tar.gz
gnu: Add emacs-orgmdb.
* gnu/packages/emacs-xyz.scm (emacs-orgmdb): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4c4b4df084..035babd18d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6010,6 +6010,29 @@ heading, other headings can be refiled to it with one command, and back to
 their original location with another.")
       (license license:gpl3+))))
 
+(define-public emacs-orgmdb
+  (package
+    (name "emacs-orgmdb")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/isamert/orgmdb.el")
+             (commit "66c13abdb84e0f0a31bae6cfda27478771d58d8e")))
+       (sha256
+        (base32
+         "1hvxha0ih9jhvwj07l6jnpf2vzhgvb6ii73g49c8saxld61l0frf"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-dash emacs-org emacs-s))
+    (home-page "https://github.com/isamert/orgmdb.el")
+    (synopsis "Emacs' Org mode watchlist manager and OMDb API client")
+    (description "This package adds tools for managing your watchlist in Emacs'
+Org mode and some functions for interacting with the OMDb API.")
+    (license license:gpl3+)))
+
 (define-public emacs-rich-minority
   (package
     (name "emacs-rich-minority")