summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-10 09:57:14 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-10 20:49:17 +0800
commitd2ab0e90c6dfd8c6382563403973f83be8133523 (patch)
treeafe1f21b7714044f2c5eee43c79ad664c820850f /gnu
parent295fc0829be8c7c34fd262512230b87b23ab1205 (diff)
downloadguix-d2ab0e90c6dfd8c6382563403973f83be8133523.tar.gz
gnu: telepathy-glib: Propagate inputs.
* gnu/packages/glib.scm (telepathy-glib): Propagate inputs dbus, dbus-glib
  and glib.  Move gobject-introspection and libxslt to 'native-inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f7e67ba9ec..b2979b24e4 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -589,14 +589,15 @@ useful for C++.")
     (build-system gnu-build-system)
     (native-inputs
      `(("glib" ,glib "bin") ; uses glib-mkenums
+       ("gobject-introspection" ,gobject-introspection)
        ("pkg-config" ,pkg-config)
-       ("python" ,python-2)))
-    (inputs
+       ("python" ,python-2)
+       ("xsltproc" ,libxslt)))
+    (propagated-inputs
+     ;; There are all in the Requires.private field of telepathy-glib.pc.
      `(("dbus" ,dbus)
        ("dbus-glib" ,dbus-glib)
-       ("glib" ,glib)
-       ("gobject-introspection" ,gobject-introspection)
-       ("libxslt" ,libxslt)))
+       ("glib" ,glib)))
     (home-page "http://telepathy.freedesktop.org/wiki/")
     (synopsis "GLib Real-time communications framework over D-Bus")
     (description "Telepathy is a flexible, modular communications framework