summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 23:06:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 23:06:41 +0100
commitd32e57248954d20ef892ee9fbc3bae9afa1299d1 (patch)
tree36942dc64e230ecfc33114abe200b04fb7d4d2f6 /gnu
parent6615a364212ac7e731ecf0e9357317257f7114de (diff)
downloadguix-d32e57248954d20ef892ee9fbc3bae9afa1299d1.tar.gz
gnu: Add r-cubature.
* gnu/packages/cran.scm (r-cubature): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1c8b9ba521..f7b657bc3a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2568,3 +2568,28 @@ chaotic time series analysis.")
      "This package provides unit root and cointegration tests encountered in
 applied econometric analysis.")
     (license license:gpl2+)))
+
+(define-public r-cubature
+  (package
+    (name "r-cubature")
+    (version "1.3-11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cubature" version))
+       (sha256
+        (base32
+         "06f6gsvbb732p80r6hxvzh4ik546icxfvx21dyh65ypmw3kgm64k"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/bnaras/cubature")
+    (synopsis "Adaptive multivariate integration over hypercubes")
+    (description
+     "This package is an R wrapper around the cubature C library for adaptive
+multivariate integration over hypercubes.  This version provides both
+@code{hcubature} and @code{pcubature} routines in addition to a vector
+interface.")
+    ;; The included cubature C library is released under GPLv2+, but the
+    ;; wrapper declares the license to be GPLv3+.
+    (license (list license:gpl2+ license:gpl3+))))