summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:52:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:37 +0200
commitd343e0fcd6675ad36b3efb017ce7546a303e0a88 (patch)
tree391b0798e6cb52794de9c7f1c8c8f117b33bd45d /gnu
parent9ed78d0e2e361fca07338c63cf95a4ec3f2d57e0 (diff)
downloadguix-d343e0fcd6675ad36b3efb017ce7546a303e0a88.tar.gz
gnu: Add texlive-plex-otf.
* gnu/packages/tex.scm (texlive-plex-otf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f28fba181..755fe8a21a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21277,6 +21277,27 @@ in eight weights: Regular, Light, ExtraLight, Thin, Bold, Text, Medium and
 SemiBold (with corresponding italics).")
     (license (list license:silofl1.1 license:lppl))))
 
+(define-public texlive-plex-otf
+  (package
+    (name "texlive-plex-otf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/plex-otf/" "tex/latex/plex-otf/")
+             (base32
+              "0xasayka8lhkn01l1535a2jy7xsp7s01hvw3kn3jk4h569dvp21g")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/plex-otf")
+    (synopsis "Support for the OpenType font IBM Plex")
+    (description
+     "This package supports the OTF fonts from the IBM Plex project.  This
+package supports only XeLaTeX or LuaLaTeX; for pdfLaTeX use
+@code{}plex-mono.sty}, @code{}plex-sans.sty}, and @code{plex-serif.sty} from
+the @code{plex} package.  IBM Plex has no math symbols.  You will have to use
+one of the existing math fonts if you need them.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-pm-isomath
   (package
     (name "texlive-pm-isomath")