summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-16 16:01:33 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-16 16:44:39 +0100
commitd3a33fe28d7933afda7bfa2e421bf0000c0c0eac (patch)
tree9bd4bcb4d00357734bc1e3193f03945b093a4f69 /gnu
parent354f4fe2926d52fcd767022cd9b5ded319807e0e (diff)
downloadguix-d3a33fe28d7933afda7bfa2e421bf0000c0c0eac.tar.gz
gnu: eigen: Run 'ctest' in verbose mode.
* gnu/packages/algebra.scm (eigen)[arguments]: Add "-V" in
  'EIGEN_CTEST_ARGS'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 41464ca882..75eaf26559 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -422,7 +422,11 @@ cosine/ sine transforms or DCT/DST).")
                              (dash-j (format #f "-j~a" cores)))
                         ;; These variables are supposed to be honored.
                         (setenv "EIGEN_MAKE_ARGS" dash-j)
-                        (setenv "EIGEN_CTEST_ARGS" dash-j)
+
+                        ;; Use '-V' to get more details in case of test
+                        ;; failures.
+                        (setenv "EIGEN_CTEST_ARGS"
+                                (string-append "-V " dash-j))
 
                         (zero? (system* "make" "buildtests" dash-j))))))))
     (home-page "http://eigen.tuxfamily.org")