summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-05-29 19:46:53 -0400
committerLudovic Courtès <ludo@gnu.org>2023-06-24 17:08:16 +0200
commitd3f5c35e407d6a3b83b9bb326a5d370280535308 (patch)
tree75e7496f834ca6fdf1aca535fc62c42dd3987762 /gnu
parent748665f49a828a953f95120fdb93a3762d0e66d7 (diff)
downloadguix-d3f5c35e407d6a3b83b9bb326a5d370280535308.tar.gz
gnu: blesh: Update to 0.4.0-devel3.
* gnu/packages/bash.scm (blesh): Update to 0.4.0-devel3.
[source]: Use recursive checkout.
[phases]: Remove 'make-readlink-work. Rename 'pretend-contrib-.git-exists
to 'pretend-.git-exists. Substitute commit_hash for package version.
[native-inputs]: Add git.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bash.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 43f38303f7..bb3359d5d1 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -445,28 +445,27 @@ you to call routines in shared libraries from within Bash.")
 (define-public blesh
   (package
     (name "blesh")
-    (version "0.4.0-devel2")
+    (version "0.4.0-devel3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/akinomyoga/ble.sh")
-                    (commit (string-append "v" version))))
+                    (commit (string-append "v" version))
+                    (recursive? #t)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "02fdjyh4x6wr5hg3i86nsxhz8ysgjrvvxdmk6pqr0lm8ngw9p3sh"))))
+                "19y9rmj9srl7akx33gl34l5qgz2ww0vlmi4j2r11029p8sn4s418"))))
     (arguments
      (list #:make-flags #~(list (string-append "PREFIX="
                                                #$output))
            #:phases #~(modify-phases %standard-phases
-                        (add-after 'unpack 'pretend-contrib-.git-exists
-                          (lambda _
-                            (mkdir-p "contrib/.git")))
-                        (add-after 'unpack 'make-readlink-work
+                        (add-after 'unpack 'pretend-.git-exists
                           (lambda _
                             (substitute* "ble.pp"
-                              (("PATH=/bin:/usr/bin readlink")
-                               "readlink"))))
+                              (("#%\\[commit_hash =.*")
+                               (string-append "#%[commit_hash = " #$version "]\n")))
+                            (mkdir-p ".git")))
                         (delete 'configure) ;no configure
                         (add-before 'check 'use-LANG-for-tests
                           (lambda _
@@ -474,7 +473,7 @@ you to call routines in shared libraries from within Bash.")
                                     (getenv "LC_ALL"))
                             (unsetenv "LC_ALL"))))))
     (build-system gnu-build-system)
-    (native-inputs (list less))
+    (native-inputs (list git less))
     (home-page "https://github.com/akinomyoga/ble.sh")
     (synopsis "Bash Line Editor")
     (description