summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-09 10:33:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-09 10:37:22 +0100
commitd42856670d043b80d9e776ab78c5f393ca103d54 (patch)
tree3b8f00c138c8a40c3b9dac5df260d8cb122e578e /gnu
parente2a0f21a5b0b081dadf1d16af0180d00b937956b (diff)
downloadguix-d42856670d043b80d9e776ab78c5f393ca103d54.tar.gz
gnu: bart: Do not build in parallel.
This is necessary for a reproducible build.

* gnu/packages/image-processing.scm (bart)[arguments]: Add PARALLEL and
PARALLEL_NJOBS to make flags; disable parallel build.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index cae9c55a73..9bf743bf45 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -117,10 +117,13 @@
       #:test-target "utest"
       #:make-flags #~(list
                       (string-append "PREFIX=" #$output)
+                      "PARALLEL=1"
+                      "PARALLEL_NJOBS=1"
                       "OPENBLAS=1"
                       "SCALAPACK=1"
                       (string-append "BLAS_BASE=" #$(this-package-input "openblas"))
                       (string-append "FFTW_BASE=" #$(this-package-input "fftw")))
+      #:parallel-build? #false ;leads to non-deterministic output
       #:phases
       #~(modify-phases %standard-phases
           (delete 'configure)