summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 20:55:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 23:34:49 -0500
commitd43568013e6fe7233f884238954295a4f7de05c5 (patch)
tree6bae1c3e13e4cfc0b06012daa7050d3ca28b9aa9 /gnu
parentdb1532e1adb2bc90bff43ab7cf40be602a208556 (diff)
downloadguix-d43568013e6fe7233f884238954295a4f7de05c5.tar.gz
gnu: Remove python2-promise.
* gnu/packages/python-xyz.scm (python2-promise): Delete variable.
(python-promise)[properties]: Delete field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab73e19c4e..ea63670d11 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13944,20 +13944,8 @@ concurrent.futures package from Python 3.2")
     (synopsis "Promises/A+ implementation for Python")
     (description
      "Promises/A+ implementation for Python")
-    (properties `((python2-variant . ,(delay python2-promise))))
     (license license:expat)))
 
-(define-public python2-promise
-  (let ((promise (package-with-python2
-                   (strip-python2-variant python-promise))))
-    (package/inherit promise
-      (arguments (substitute-keyword-arguments (package-arguments promise)
-                   ((#:tests? _) #t)))
-      (native-inputs
-       `(("python2-futures" ,python2-futures)
-         ("python2-pytest" ,python2-pytest)
-         ,@(package-native-inputs promise))))))
-
 (define-public python-progressbar2
   (package
     (name "python-progressbar2")