summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-07 16:13:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-07 16:16:13 +0300
commitd46e9fcb2cd637d5f7695638679229dd72d858b4 (patch)
treeacf829793f57992cf4e19cbd1b01f2cb335e61a2 /gnu
parentecc39b3f55be18f9c9d9b71b2d12f037299433f2 (diff)
downloadguix-d46e9fcb2cd637d5f7695638679229dd72d858b4.tar.gz
gnu: myrepos: Update to 1.20170129.
* gnu/packages/version-control.scm (myrepos): Update to 1.20170129.
[source]: Source tarballs have been removed from Github, use
git-download to download from upstream repository.
[home-page]: Use https.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6d94170f3c..920e67e74a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1171,24 +1171,24 @@ modification time.")
 (define-public myrepos
   (package
     (name "myrepos")
-    (version "1.20160123")
+    (version "1.20170129")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/joeyh/myrepos/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "git://myrepos.branchable.com/myrepos")
+             (commit version)))
+       (file-name (string-append name "-" version "-checkout"))
        (sha256
-        (base32 "1723cg5haplz2w9dwdzp6ds1ip33cx3awmj4wnb0h4yq171v5lqk"))))
+        (base32 "15i9bs2i25l7ibv530ghy8280kklcgm5kr6j86s7iwcqqckd0czp"))))
     (build-system gnu-build-system)
     (inputs
      `(("perl" ,perl)))
     (arguments
-     `(#:test-target "test"
+     '(#:test-target "test"
        #:phases (alist-delete 'configure %standard-phases)
        #:make-flags (list (string-append "PREFIX=" %output))))
-    (home-page "http://myrepos.branchable.com/")
+    (home-page "https://myrepos.branchable.com/")
     (synopsis "Multiple repository management tool")
     (description
      "Myrepos provides the @code{mr} command, which maps an operation (e.g.,