summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-25 23:07:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-11-02 13:07:19 +0100
commitd4a4d5da604adcf10cf707d2801ca89a782996c4 (patch)
tree66c95e34f1d9f55dfafc2b251d68831621e2e366 /gnu
parent8d6a48150aab886c24c3c05849c04d71fc2f8087 (diff)
downloadguix-d4a4d5da604adcf10cf707d2801ca89a782996c4.tar.gz
gnu: Add java-powermock-core.
* gnu/packages/java.scm (java-powermock-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 80603dc37f..e78bca326c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6825,3 +6825,21 @@ constructors, final classes and methods, private methods, removal of static
 initializers and more.  By using a custom classloader no changes need to be
 done to the IDE or continuous integration servers which simplifies adoption.")
     (license license:asl2.0)))
+
+(define-public java-powermock-core
+  (package
+    (inherit java-powermock-reflect)
+    (name "java-powermock-core")
+    (arguments
+     `(#:jar-name "java-powermock-core.jar"
+       #:source-dir "powermock-core/src/main/java"
+       #:test-dir "powermock-core/src/test"
+       #:tests? #f; requires powermock-api
+       #:jdk ,icedtea-8))
+    (inputs
+     `(("reflect" ,java-powermock-reflect)
+       ("javassist" ,java-jboss-javassist)))
+    (native-inputs
+     `(("junit" ,java-junit)
+       ("assertj" ,java-assertj)
+       ("mockito" ,java-mockito-1)))))