summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 18:08:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:31 +0200
commitd5794c9716584c94962f8dd941128a35745ca0b9 (patch)
treeddb3fae3c600ffe1b95a73a2e2534dfd3d00397b /gnu
parente198500f9a1ea7fa5891f07b688436b5a794c8ce (diff)
downloadguix-d5794c9716584c94962f8dd941128a35745ca0b9.tar.gz
gnu: Add texlive-lithuanian.
* gnu/packages/tex.scm (texlive-lithuanian): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f25844f22a..89bbde036e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4794,6 +4794,36 @@ simple roots of any complex simple Lie algebra.  It uses the Dynkin diagrams
 package @code{dynkin-diagrams}.")
     (license license:lppl1.3c)))
 
+(define-public texlive-lithuanian
+  (package
+    (name "texlive-lithuanian")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/lithuanian/"
+                   "fonts/enc/dvips/lithuanian/"
+                   "fonts/map/dvips/lithuanian/"
+                   "fonts/tfm/public/lithuanian/"
+                   "tex/latex/lithuanian/")
+             (base32
+              "1iq06vlryl4fj2mzkmmphw9ihm0y7wmi5k8wxniaciw5mm5vrw7x")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lithuanian")
+    (synopsis "Lithuanian language support")
+    (description
+     "This language support package provides:
+
+@itemize
+@item extra 8-bit encoding L7x used by @code{fontenc}: @file{l7xenc.def},
+@file{l7xenc.dfu}, @file{l7xenc.sty};
+@item Lithuanian TeX support for URW family Type1 fonts: map, fd, tfm with L7x
+encoding;
+@item extra code page definitions used by @code{inputenc}: @file{cp775.def}
+and @file{latin7.def}.
+@end itemize")
+    (license license:lppl1.3c)))
+
 (define-public texlive-logicproof
   (package
     (name "texlive-logicproof")