summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 21:00:40 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitd5f89b22d82fb1c7f41b784f2711d898ce81396b (patch)
tree0a7edd69bb4a915e28e76ff1325574e874128abd /gnu
parentc7303d3cef71dbe7fad2d082126e787a4385c765 (diff)
downloadguix-d5f89b22d82fb1c7f41b784f2711d898ce81396b.tar.gz
gnu: Add python-pyld.
* gnu/packages/python.scm (python-pyld, python2-pyld): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 17147b96bc..ad5def2a8c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -995,3 +995,29 @@ files.")
 
 (define-public python2-exif-read
   (package-with-python2 python-exif-read))
+
+(define-public python-pyld
+  (package
+    (name "python-pyld")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append
+                "https://pypi.python.org/packages/source/P/PyLD/PyLD-"
+                version ".tar.gz"))
+              (sha256
+               (base32
+                "1l9ymj85fsvayqplinzpk0kyiq6m74ps9xd3a9fhlxfn1rldf8x8"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (arguments `(#:tests? #f)) ; no tests
+    (home-page "http://github.com/digitalbazaar/pyld")
+    (synopsis "Python implementation of the JSON-LD specification")
+    (description
+     "PyLD is an implementation of the JSON-LD specification.")
+    (license bsd-3)))
+
+(define-public python2-pyld
+  (package-with-python2 python-pyld))