summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-22 13:10:34 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-24 13:22:57 +0200
commitd649704ebc647719d23407aeb312f103001c32d7 (patch)
tree7c4bc234b79978070ea40ffc84b5678dc3ebe612 /gnu
parent6de7e59f8b172c6677c7463c72dfe5bf57cbef11 (diff)
downloadguix-d649704ebc647719d23407aeb312f103001c32d7.tar.gz
gnu: python-trytond: Update to 5.6.5.
* gnu/packages/tryton.scm (python-trytond): Update to 5.6.5.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 10d349844f..85d9a12425 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -27,6 +27,7 @@
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages time)
@@ -38,25 +39,23 @@
 (define-public python-trytond
   (package
     (name "python-trytond")
-    (version "4.6.2")
+    (version "5.6.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "trytond" version))
        (sha256
-        (base32
-         "0asc3pd37h8ky8j66iqxr0fv0k6mpjcwxwm0xgm5hrdi32l5cdda"))))
+        (base32 "1n76ccv2x5csz80p42dav8rhzg2m14wdi3bj1pizhw8x2hxxfwx3"))))
     (build-system python-build-system)
     (inputs
      `(("python-dateutil" ,python-dateutil)
        ("python-genshi" ,python-genshi)
-       ("python-polib" ,python-polib)
+       ("python-lxml" ,python-lxml)
        ("python-magic" ,python-magic)
-       ;; there's no python-mysql in Guix right now
-       ;; so python-psycopg2 (postgresql) only for now
+       ("python-passlib" ,python-passlib)
+       ("python-polib" ,python-polib)
        ("python-psycopg2" ,python-psycopg2)
        ("python-relatorio" ,python-relatorio)
-       ("python-lxml" ,python-lxml)
        ("python-sql" ,python-sql)
        ("python-werkzeug" ,python-werkzeug)
        ("python-wrapt" ,python-wrapt)))
@@ -68,6 +67,7 @@
          (add-before 'check 'preparations
            (lambda _
              (setenv "DB_NAME" ":memory:")
+             (setenv "HOME" "/tmp")
              #t)))))
     (home-page "https://www.tryton.org/")
     (synopsis "Server component of Tryton")