summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-04-06 00:52:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:29:25 -0400
commitd6c4010fbc9554b18767caf7f5ba34aa279f5f72 (patch)
treea808de47ebae6afee1ac5588a4db4e407603ae57 /gnu
parent0f3e9c52f390efe77ae1e6835775524249b344d9 (diff)
downloadguix-d6c4010fbc9554b18767caf7f5ba34aa279f5f72.tar.gz
gnu: Add emacs-flymake-popon.
* gnu/packages/emacs-xyz.scm (emacs-flymake-popon): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 84642bae71..8efd1b0029 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2305,6 +2305,29 @@ and help selectively enable or disable diagnostic functions based on major
 modes.")
     (license license:expat)))
 
+(define-public emacs-flymake-popon
+  (package
+    (name "emacs-flymake-popon")
+    (version "0.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/akib/emacs-flymake-popon")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ljqnnl5k2f62ilahilx0ldv0spjp9hpgyikd4py1348flzq4k31"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+      (list emacs-popon
+            emacs-posframe))
+    (home-page "https://codeberg.org/akib/emacs-flymake-popon")
+    (synopsis "Flymake diagnostics on cursor hover")
+    (description "This package shows Flymake diagnostics on cursor hover.")
+    (license license:gpl3+)))
+
 (define-public emacs-flymake-flycheck
   (package
     (name "emacs-flymake-flycheck")