summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:59 +0300
commitd721e349a1f58591cab608ed079247ad415dd3a9 (patch)
tree88f5f5cbf30106004fde5077c8b189b86a7aef65 /gnu
parent4d6084fc888cb95d1274d0f39d26569a0752b194 (diff)
downloadguix-d721e349a1f58591cab608ed079247ad415dd3a9.tar.gz
gnu: Add rust-unescape-0.1.
* gnu/packages/crates-io.scm (rust-unescape-0.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9a1d118601..6d63c40bac 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -70332,6 +70332,24 @@ arithmetic.")
      "Unchecked indexing wrapper using regular index syntax.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-unescape-0.1
+  (package
+    (name "rust-unescape")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "unescape" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0vlgws15n4kz8xq4igzr1f80nbiyr838k687hn6ly8a36an7vffc"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/saghm/unescape-rs")
+    (synopsis "Unescapes strings")
+    (description
+     "Unescapes strings with escape sequences written out as literal characters.")
+    (license license:expat)))
+
 (define-public rust-ungrammar-1
   (package
     (name "rust-ungrammar")