summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-12 22:51:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 20:18:42 +0100
commitd7636c8bb7f2498f11d930a363061e4754e75724 (patch)
tree449cbcd4dafae3f1401e305627cebc2576422498 /gnu
parent6472ccf4dba5ac343cdcd15c42d4d2bec67df654 (diff)
downloadguix-d7636c8bb7f2498f11d930a363061e4754e75724.tar.gz
gnu: python-pytorch-for-r-torch: Reuse python-pytorch.
* gnu/packages/machine-learning.scm (python-pytorch-for-r-torch): Use
definition on python-pytorch, thereby updating to 1.10.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm47
1 files changed, 1 insertions, 46 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 2f7e1ac5d9..2067960720 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3034,52 +3034,7 @@ PyTorch when needed.
 Note: currently this package does not provide GPU support.")
     (license license:bsd-3)))
 
-(define-public python-pytorch-for-r-torch
-  (package
-    (inherit python-pytorch)
-    (name "python-pytorch")
-    (version "1.9.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/pytorch/pytorch")
-                    (commit (string-append "v" version))
-                    (recursive? #t)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0cznsh68hwk5761gv7iijb4g6jgjpvs3bbixwpzzmkbkbn2q96c1"))
-              (patches (search-patches "python-pytorch-1.9.0-system-libraries.patch"
-                                       "python-pytorch-runpath.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  ;; XXX: Let's be clear: this package is a bundling fest.  We
-                  ;; delete as much as we can, but there's still a lot left.
-                  (for-each (lambda (directory)
-                              (delete-file-recursively
-                               (string-append "third_party/" directory)))
-                            '("benchmark" "cpuinfo" "eigen"
-
-                              ;; FIXME: QNNPACK (of which XNNPACK is a fork)
-                              ;; needs these.
-                              ;; "FP16" "FXdiv" "gemmlowp" "psimd"
-
-                              "gloo" "googletest" "ios-cmake" "NNPACK"
-                              "onnx" "protobuf" "pthreadpool"
-                              "pybind11" "python-enum" "python-peachpy"
-                              "python-six" "tbb" "XNNPACK" "zstd"))
-
-                  ;; Adjust references to the onnx-optimizer headers.
-                  (substitute* "caffe2/onnx/backend.cc"
-                    (("onnx/optimizer/")
-                     "onnxoptimizer/"))))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments python-pytorch)
-       ((#:phases phases '%standard-phases)
-        `(modify-phases ,phases
-           ;; No module named 'onnx.optimizer'
-           (delete 'sanity-check)))))))
+(define-public python-pytorch-for-r-torch python-pytorch)
 
 (define-public python-hmmlearn
   (package