summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2022-08-22 18:01:58 -0400
committerMark H Weaver <mhw@netris.org>2022-08-23 12:59:09 -0400
commitd769cf81d83d75400e5ed0394b839d8ddb770384 (patch)
tree93381ee42eb6ecb74407217c7d954946f8683e86 /gnu
parentd26b29d263e2a3ce5c7ef446f4bfcdcec75ab39f (diff)
downloadguix-d769cf81d83d75400e5ed0394b839d8ddb770384.tar.gz
gnu: icecat: Update to 91.13.0-guix0-preview1 [security fixes].
Includes fixes for CVE-2022-38472, CVE-2022-38473, and CVE-2022-38478.

* gnu/packages/gnuzilla.scm (%icecat-version, %icecat-build-id): Update.
(icecat-source): Update gnuzilla commit, base version, and hashes.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a914650506..4c08ef6095 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -371,8 +371,8 @@ in C/C++.")
 ;; XXXX: Workaround 'snippet' limitations.
 (define computed-origin-method (@@ (guix packages) computed-origin-method))
 
-(define %icecat-version "91.12.0-guix0-preview1")
-(define %icecat-build-id "20220726000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-version "91.13.0-guix0-preview1")
+(define %icecat-build-id "20220823000000") ;must be of the form YYYYMMDDhhmmss
 
 ;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
 ;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -394,11 +394,11 @@ in C/C++.")
                   "firefox-" upstream-firefox-version ".source.tar.xz"))
             (sha256
              (base32
-              "0p1bhc1qla4a7iqk0fc6sj224ld6wplpmj4yw6nfx1b8hbqqy2vc"))))
+              "0qh7j960wdp5zcfqhkj8ki47spp9i9ms12xx0v0kxvmmw36jpgjk"))))
 
-         (upstream-icecat-base-version "91.12.0") ; maybe older than base-version
+         (upstream-icecat-base-version "91.13.0") ; maybe older than base-version
          ;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
-         (gnuzilla-commit "298024d727053a1609df4003fb4438836d5181f4")
+         (gnuzilla-commit "4a87716686104266a9cccc2d83cc249e312f3673")
          (gnuzilla-source
           (origin
             (method git-fetch)
@@ -410,7 +410,7 @@ in C/C++.")
                                       (string-take gnuzilla-commit 8)))
             (sha256
              (base32
-              "1lgz6knklxbrqr1vaj9d0y0997f4f6v44a8cng8ihkmn7aa7lvwg"))))
+              "070j78al04xzchfl5xj1w300hmw17a3iqcw7mnlxf6b8rqlgj20p"))))
 
          ;; 'search-patch' returns either a valid file name or #f, so wrap it
          ;; in 'assume-valid-file-name' to avoid 'local-file' warnings.