summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-05 17:47:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-05 23:36:06 +0100
commitd7ca0f73ff6db21ec254c7a229feb3467103154f (patch)
tree5741326d184c6e85618082956decdaaaf492b4db /gnu
parent44a33ee90dbd97abf388fc45a7f4cd41cbc8171f (diff)
downloadguix-d7ca0f73ff6db21ec254c7a229feb3467103154f.tar.gz
gnu: coreutils: Update to 8.32.
* gnu/packages/base.scm (coreutils): Update to 8.32.
[arguments]: Remove obsolete phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 13bcf7fe9d..1989bdd7eb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -290,14 +290,14 @@ used to apply commands with arbitrarily long arguments.")
 (define-public coreutils
   (package
    (name "coreutils")
-   (version "8.31")
+   (version "8.32")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/coreutils/coreutils-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "1zg9m79x1i2nifj4kb0waf9x3i5h6ydkypkjnbsb9rnwis8rqypz"))))
+              "1yjcrh5hw70c0yn8zw55pd6j51dj90anpq8mmg649ps9g3gdhn24"))))
    (build-system gnu-build-system)
    (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)                        ;bignums in 'expr', yay!
@@ -329,16 +329,6 @@ used to apply commands with arbitrarily long arguments.")
                        (("/bin/sh") (which "sh")))
                      (substitute* (find-files "tests" "\\.sh$")
                        (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                     #t))
-                 (add-before 'check 'disable-broken-test
-                   (lambda _
-                     ;; This test hits the 127 character shebang limit in the build
-                     ;; environment due to the way "env -S" splits arguments into
-                     ;; shebangs.  Note that "env-S-script.sh" works around this
-                     ;; specific issue, but "env-S.pl" is not adjusted for build
-                     ;; environments with long prefixes (/tmp/guix-build-...).
-                     (substitute* "Makefile"
-                       (("^.*tests/misc/env-S.pl.*$") ""))
                      #t)))))
    (synopsis "Core GNU utilities (file, text, shell)")
    (description