summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-06-26 22:31:41 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-06-30 00:07:55 +0200
commitd889e6c4d9af68701be3e8a12bc377369d1c8625 (patch)
tree747caed6a03dcf667192ded36a26b4963a42de44 /gnu
parentfe36d84eae08c485f4991f0e2ee0e53d55833f26 (diff)
downloadguix-d889e6c4d9af68701be3e8a12bc377369d1c8625.tar.gz
gnu: Add python-pep8.
* gnu/packages/python.scm (python-pep8, python2-pep8): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1b3934b351..0bcaf5df8e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3902,3 +3902,30 @@ applications.")
 
 (define-public python2-pyzmq
   (package-with-python2 python-pyzmq))
+
+(define-public python-pep8
+  (package
+    (name "python-pep8")
+    (version "1.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/p/pep8/pep8-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "1zybkcdw1sx84dvkfss96nhykqg9bc0cdpwpl4k9wlxm61bf7dxq"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://pep8.readthedocs.org/")
+    (synopsis "Python style guide checker")
+    (description
+     "This tools checks Python code against some of the style conventions in
+PEP 8.")
+    (license license:expat)))
+
+(define-public python2-pep8
+  (package-with-python2 python-pep8))