summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:22:29 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitd8fa80e13fbe7295dd85dffd89e15bbf748f5143 (patch)
tree88c404231751b9e8c4b7963f4c55834820cd4a08 /gnu
parent84d240172863e293ed25f38469e9676afb3c2aa9 (diff)
downloadguix-d8fa80e13fbe7295dd85dffd89e15bbf748f5143.tar.gz
gnu: Add python-testtools.
* gnu/packages/python.scm (python-testtools, python2-testtools): New
  variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5235ced452..b02f91e464 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1154,6 +1154,36 @@ subprocess and see the output as well as any file modifications.")
 (define-public python2-scripttest
   (package-with-python2 python-scripttest))
 
+(define-public python-testtools
+  (package
+    (name "python-testtools")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/t/testtools/testtools-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1dyml28ykpl5jb9khdmcdvhy1cxqingys6qvj2k04fzlaj6z3bbx"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-mimeparse" ,python-mimeparse)
+       ("python-extras" ,python-extras)))
+    (home-page "https://github.com/testing-cabal/testtools")
+    (synopsis
+     "Extensions to the Python standard library unit testing framework")
+    (description
+     "Testtools extends the Python standard library unit testing framework to
+provide matchers, more debugging information, and cross-Python
+compatibility.")
+    (license psfl)))
+
+(define-public python2-testtools
+  (package-with-python2 python-testtools))
+
 (define-public behave
   (package
     (name "behave")