summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <contact@phfrohring.com>2022-02-06 15:47:23 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-24 23:26:56 +0100
commitd90b06cc428146347b0f44faf963c03543854a4e (patch)
tree00f5d044a7fdfa42ee46a0c20363811d4b975053 /gnu
parent66cd0ce176fcebb21a0270083b1bb76ccd170d13 (diff)
downloadguix-d90b06cc428146347b0f44faf963c03543854a4e.tar.gz
gnu: Add python-aiopg.
* gnu/packages/python-xyz.scm (python-aiopg): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb50741f0e..e2bb1ca4ef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29274,3 +29274,24 @@ writing STL files.  It supports both the text and binary forms of STL.")
     (description
      "This package provides a streaming multipart parser for Python.")
     (license license:asl2.0)))
+
+(define-public python-aiopg
+  (package
+    (name "python-aiopg")
+    (version "1.3.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "aiopg" version))
+              (sha256
+               (base32
+                "1mwmypsfzh8adjbyvf7kqv9h3k1kf5ykhi1g3ahw4wqdxaj6nz2l"))))
+    (build-system python-build-system)
+    (native-inputs (list python-sqlalchemy))
+    (propagated-inputs (list python-async-timeout python-psycopg2-binary))
+    (home-page "https://aiopg.readthedocs.io")
+    (synopsis "Postgres integration with asyncio")
+    (description
+     "aiopg is a library for accessing a PostgreSQL
+database from the asyncio (PEP-3156/tulip) framework.  It wraps
+asynchronous features of the Psycopg database driver.")
+    (license license:bsd-3)))