summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-22 11:26:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:02 +0300
commitd94fe3daf74023952620498ad30d6ca9c8882587 (patch)
treef1eff5846f4963e965409f8c81757d23e44fcb37 /gnu
parent1af6671474fd922b3e659762353a0d33fe849df0 (diff)
downloadguix-d94fe3daf74023952620498ad30d6ca9c8882587.tar.gz
gnu: Add rust-rustls-pemfile-1.
* gnu/packages/crates-io.scm (rust-rustls-pemfile-1): New variable.
(rust-rustls-pemfile-0.2): Inherit from rust-rustls-pemfile-1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fcec0512ea..9843404197 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -50757,29 +50757,47 @@ native certificate store.")
         ("rust-webpki" ,rust-webpki-0.21)
         ("rust-webpki-roots" ,rust-webpki-roots-0.20))))))
 
-(define-public rust-rustls-pemfile-0.2
+(define-public rust-rustls-pemfile-1
   (package
     (name "rust-rustls-pemfile")
-    (version "0.2.1")
+    (version "1.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "rustls-pemfile" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1jfi97lqnnnnxhmfy6ygrsp0x70m8wsdpaw45svvz1qc6vmymssy"))))
+        (base32 "16x5jhja8z0j5hcrlaqqz5qnyg9qgv8qqffwbdil6fl0b1nvb56i"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-base64" ,rust-base64-0.13))
+       (("rust-base64" ,rust-base64-0.21))
        #:cargo-development-inputs
-       (("rust-criterion" ,rust-criterion-0.3))))
+       (("rust-bencher" ,rust-bencher-0.1))))
     (home-page "https://github.com/rustls/pemfile")
     (synopsis "Basic parser for PEM formatted keys and certificates")
     (description "This package provides a very basic parser for the
 PEM-encodings commonly used to store keys and certificates at rest.")
     (license (list license:asl2.0 license:isc license:expat))))
 
+(define-public rust-rustls-pemfile-0.2
+  (package
+    (inherit rust-rustls-pemfile-1)
+    (name "rust-rustls-pemfile")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustls-pemfile" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1jfi97lqnnnnxhmfy6ygrsp0x70m8wsdpaw45svvz1qc6vmymssy"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-base64" ,rust-base64-0.13))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.3))))))
+
 (define-public rust-rusttype-0.9
   (package
     (name "rust-rusttype")