summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 15:36:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:29 +0200
commitd9a7fab6471260465fa8a7b95b91e17bcf00b13f (patch)
tree54fb7e2c61db931fc9513ca3a8dae18c05de1303 /gnu
parent5bad645159f34070c326e5e0f91b8ae7f4cfd269 (diff)
downloadguix-d9a7fab6471260465fa8a7b95b91e17bcf00b13f.tar.gz
gnu: squeak-vm: Return #t from phases.
* gnu/packages/smalltalk.scm (squeak-vm)[arguments]: Substitute INVOKE
for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/smalltalk.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/smalltalk.scm b/gnu/packages/smalltalk.scm
index c0c53a5291..9b36d83a80 100644
--- a/gnu/packages/smalltalk.scm
+++ b/gnu/packages/smalltalk.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -132,14 +133,15 @@ such as ones for networking and GUI programming.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (with-directory-excursion "bld"
-                 (zero?
-                  (system* "../unix/cmake/configure"
+                 (invoke "../unix/cmake/configure"
                            (string-append "--prefix=" out)
-                           "--without-quartz"))))))
+                           "--without-quartz")
+                 #t))))
          (replace 'build
            (lambda _
              (with-directory-excursion "bld"
-               (zero? (system* "make"))))))))
+               (invoke "make"))
+             #t)))))
     (synopsis "Smalltalk programming language and environment")
     (description "Squeak is a full-featured implementation of the Smalltalk
 programming language and environment based on (and largely compatible with)