summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:04:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:11 +0200
commitd9cb14e78ebd72c016392f2d2f2101a0ce07ef70 (patch)
tree72226985380927b2e0c59a436138b4c9d625f3f9 /gnu
parent6e4058fb0f5a7b96a0b43927fcedb13b386d84cb (diff)
downloadguix-d9cb14e78ebd72c016392f2d2f2101a0ce07ef70.tar.gz
gnu: Add rust-glutin-0.31.
* gnu/packages/crates-graphics.scm (rust-glutin-0.31): New variable.
(rust-glutin-0.30): Inherit from rust-glutin-0.31.

Change-Id: Ie8e14ebb833249f359591891cba7fbfd5fdafe18
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm42
1 files changed, 36 insertions, 6 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 54e23dff90..5f60b36213 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1336,8 +1336,43 @@ EUI-64, also known as MAC-48 media access control addresses.")
      "Generated OpenGL bindings and wrapper for Servo.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-glutin-0.31
+  (package
+    (name "rust-glutin")
+    (version "0.31.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "glutin" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "04mjvgh2dipwa8wdy8gc70k8w48104v8vmr2cmqdqspq5ai5jm00"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+                       ("rust-cfg-aliases" ,rust-cfg-aliases-0.1)
+                       ("rust-cgl" ,rust-cgl-0.3)
+                       ("rust-core-foundation" ,rust-core-foundation-0.9)
+                       ("rust-dispatch" ,rust-dispatch-0.2)
+                       ("rust-glutin-egl-sys" ,rust-glutin-egl-sys-0.6)
+                       ("rust-glutin-glx-sys" ,rust-glutin-glx-sys-0.5)
+                       ("rust-glutin-wgl-sys" ,rust-glutin-wgl-sys-0.5)
+                       ("rust-icrate" ,rust-icrate-0.0.4)
+                       ("rust-libloading" ,rust-libloading-0.8)
+                       ("rust-objc2" ,rust-objc2-0.4)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-raw-window-handle" ,rust-raw-window-handle-0.5)
+                       ("rust-wayland-sys" ,rust-wayland-sys-0.31)
+                       ("rust-windows-sys" ,rust-windows-sys-0.48)
+                       ("rust-x11-dl" ,rust-x11-dl-2))))
+    (home-page "https://github.com/rust-windowing/glutin")
+    (synopsis "Cross-platform OpenGL context provider")
+    (description "This package provides an OpenGL context provider.")
+    (license license:asl2.0)))
+
 (define-public rust-glutin-0.30
   (package
+    (inherit rust-glutin-0.31)
     (name "rust-glutin")
     (version "0.30.7")
     (source
@@ -1347,7 +1382,6 @@ EUI-64, also known as MAC-48 media access control addresses.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "05gzw9icj4s0p9db9srnwrd3m3plcs7260jlblyy2pbiqygap6zq"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-bitflags" ,rust-bitflags-1)
@@ -1364,11 +1398,7 @@ EUI-64, also known as MAC-48 media access control addresses.")
         ("rust-raw-window-handle" ,rust-raw-window-handle-0.5)
         ("rust-wayland-sys" ,rust-wayland-sys-0.30)
         ("rust-windows-sys" ,rust-windows-sys-0.45)
-        ("rust-x11-dl" ,rust-x11-dl-2))))
-    (home-page "https://github.com/tomaka/glutin")
-    (synopsis "Cross-platform OpenGL context provider")
-    (description "This package provides an OpenGL context provider.")
-    (license license:asl2.0)))
+        ("rust-x11-dl" ,rust-x11-dl-2))))))
 
 (define-public rust-glutin-0.28
   (package