summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-26 19:50:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-03-26 20:41:50 +0200
commitda5fe92a0b64c947b0e95c4076fdfd4fe1ab8f1c (patch)
tree9a6bd2396593d70369dac1937475947152bcc7c4 /gnu
parent03a34d54129fadd7dc174fe294c1735e4a4c10ff (diff)
downloadguix-da5fe92a0b64c947b0e95c4076fdfd4fe1ab8f1c.tar.gz
gnu: Add ghc-basement.
* gnu/packages/haskell.scm (ghc-basement): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0bc8e52fde..5de9f51a2f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9023,4 +9023,24 @@ Haskell programmers.  The ultimate goal is to support all Amazon
 Web Services.")
     (license license:bsd-3)))
 
+(define-public ghc-basement
+  (package
+    (name "ghc-basement")
+    (version "0.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "basement/basement-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0w2g4k9bs2ph00p0fgrmcrng8ypdz6xis0r10g380nzkg2rvj0dm"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/haskell-foundation/foundation")
+    (synopsis "Basic primitives for Foundation starter pack")
+    (description
+     "This package contains basic primitives for the Foundation set of
+packages.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here