summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-03 16:49:40 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-03 16:49:40 +0800
commitdac354fe10c31a3c68fa328628c9197e8bee052f (patch)
tree98759f51d6d664feac84d0c52c694105738b1da9 /gnu
parentc22eb9927f1ca6e8a724f9e634ce14700f888c6b (diff)
downloadguix-dac354fe10c31a3c68fa328628c9197e8bee052f.tar.gz
gnu: Add libinput.
* gnu/packages/freedesktop.scm (libinput): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm37
1 files changed, 34 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 0ee639d20a..f65a5bbf9d 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17,10 +18,14 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages freedesktop)
-  #:use-module ((guix licenses) #:select (expat))
+  #:use-module ((guix licenses) #:select (expat x11))
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xdisorg)
+  #:use-module (gnu packages xorg))
 
 (define-public xdg-utils
   (package
@@ -43,4 +48,30 @@
     (description "The xdg-utils package is a set of simple scripts that
 provide basic desktop integration functions in the framework of the
 freedesktop.org project.")
-    (license expat)))
\ No newline at end of file
+    (license expat)))
+
+(define-public libinput
+  (package
+    (name "libinput")
+    (version "0.13.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://freedesktop.org/software/libinput/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "06n6ih2bfr957rprsgjxhi6f7m96wmf4kgac8y0ispsjvrzszv3c"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("libudev" ,eudev))) ; required by libinput.pc
+    (inputs
+     `(("libevdev" ,libevdev)
+       ("mtdev" ,mtdev)))
+    (home-page "http://www.freedesktop.org/wiki/Software/libinput/")
+    (synopsis "Input devices handling library")
+    (description
+     "Libinput is a library to handle input devices for display servers and
+other applications that need to directly deal with input devices.")
+    (license x11)))