summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJuliana Sims <juli@incana.org>2023-05-13 13:31:39 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-22 17:05:22 +0200
commitdaeafac0c4b00cb95fbe50372428830f6be1059a (patch)
tree687285f4310edff8c895f54ef3f0121e1d4e9101 /gnu
parent75ae763b4e09f5f7f0b21d28b4f308bcb02f1876 (diff)
downloadguix-daeafac0c4b00cb95fbe50372428830f6be1059a.tar.gz
gnu: python-txtorcon: Run guix style.
* gnu/packages/python-crypto.scm (python-txtorcon): Run guix style.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index be3ab5d0be..6a7611ccdb 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1248,31 +1248,28 @@ Password-Authenticated Key Exchange algorithm.")
   (package
     (name "python-txtorcon")
     (version "19.0.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "txtorcon" version))
-        (sha256
-         (base32
-          "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
-        (modules '((guix build utils)))
-        (snippet
-         #~(substitute* "txtorcon/controller.py"
-             (("from collections import Sequence")
-              "from collections.abc import Sequence")))))
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "txtorcon" version))
+              (sha256
+               (base32
+                "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
+              (modules '((guix build utils)))
+              (snippet #~(substitute* "txtorcon/controller.py"
+                           (("from collections import Sequence")
+                            "from collections.abc import Sequence")))))
     (build-system python-build-system)
     (arguments
-      ;; The tests fail immediately due to a missing file. Reported upstream:
-      ;; <https://github.com/meejah/txtorcon/issues/330>
-     `(#:tests? #f))
-    (propagated-inputs
-     (list python-automat
-           python-idna
-           python-incremental
-           python-pyopenssl
-           python-service-identity
-           python-twisted
-           python-zope-interface))
+     ;; The tests fail immediately due to a missing file. Reported upstream:
+     ;; <https://github.com/meejah/txtorcon/issues/330>
+     (list #:tests? #f))
+    (propagated-inputs (list python-automat
+                             python-idna
+                             python-incremental
+                             python-pyopenssl
+                             python-service-identity
+                             python-twisted
+                             python-zope-interface))
     (home-page "https://github.com/meejah/txtorcon")
     (synopsis "Twisted-based Tor controller client")
     (description "This package provides a Twisted-based Tor controller client,