summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:58 +0200
commitdb6478ad42e6fc33def229aea0a43dd3fc748237 (patch)
treeb28bac1bb638a17f494cbc3ba290b187b0b93c8e /gnu
parent68d22faea3b9f053c966fd4b361d3194e11a9781 (diff)
downloadguix-db6478ad42e6fc33def229aea0a43dd3fc748237.tar.gz
gnu: Add texlive-titlecaps.
* gnu/packages/tex.scm (texlive-titlecaps): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 02ad707b99..e8c00a9768 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -98218,6 +98218,29 @@ viewed as an ASCII-based input method for producing IPA characters in Unicode.
 It needs the New Computer Modern font for printing IPA characters.")
     (license (list license:gpl3+ license:fdl1.3+))))
 
+(define-public texlive-titlecaps
+  (package
+    (name "texlive-titlecaps")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/titlecaps/"
+                   "tex/latex/titlecaps/")
+             (base32
+              "0v921cy02dm72q60976vijpcbp5zpwljgr7y8ry5n4gqzzinnfbj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/titlecaps")
+    (synopsis "Setting rich-text input into titling caps")
+    (description
+     "The package is intended for setting rich text into titling capitals (in which
+the first character of words are capitalized).  It automatically accounts for
+diacritical marks (like umlauts), national symbols (like @samp{ae}),
+punctuation, and font changing commands that alter the appearance or size of
+the text.  It allows a list of predesignated words to be protected as
+lower-cased, and also allows for titling exceptions of various sorts.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar